Faculty of Engineering and Mathematical Sciences 
Not logged in (login)

help3003


This forum is provided to promote discussion amongst students enrolled in Graphics and Animation (CITS3003).
 
Options:
RSS cloud
Jump to:

Makefile for Lab4

3 of 275 articles shown, currently no other people reading this forum.
photo
From: ANONYMOUS
Date: Thu 26th Mar, 3:43pm
Actions: 
        Login-to-reply
Hi,

Is the makefile needed for lab 4(from lab 3 solutions), the same as the default one from the labs-examples folder? Because my output display screen is usually a blank or black screen when I do questions like 3 and 4 from lab4. 

Makefile for Lab4

photo
From: ANONYMOUS
Date: Fri 27th Mar, 9:35am
Actions: 
        Login-to-reply
I've used the same Makefile for labs 1 to 4 with no issues. 
I think that could be something else.
Maybe variables aren't being passed properly to the vertex shader.
Try moving calculations out of it into your application code.

Makefile for Lab4

photo
From: Mohammad J.
Date: Fri 27th Mar, 12:24pm
Actions: 
        Login-to-reply
ANONYMOUS wrote:

> I've used the same Makefile for labs 1 to 4 with no issues. 
> I think that could be something else.
> Maybe variables aren't being passed properly to the vertex shader.
> Try moving calculations out of it into your application code.

Hi,

Makefile's purpose is to compile your program, if you can see an executable binary then makefile is working perfectly. 

There is some issue in your code that is why you are having a black screen. OpenGL is unable to understand what it should be printing on the screen. 

Regards,
This Page


Program written by: [email protected]
Feedback welcome
Last modified:  8:27am May 24 2020